summaryrefslogtreecommitdiffstats
path: root/libtdegames/carddecks/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-06-10 21:25:06 +0200
committerSlávek Banko <[email protected]>2020-06-12 14:19:33 +0200
commita25cdc59c6302046b3121276f5a33f6b1b55a538 (patch)
tree5c41c38d0c81e99bfe2d3a8564af42cc2d92941f /libtdegames/carddecks/CMakeLists.txt
parentdc556f3e9a46e749b36cf773f9211db4ce58d96b (diff)
downloadtdegames-a25cdc59c6302046b3121276f5a33f6b1b55a538.tar.gz
tdegames-a25cdc59c6302046b3121276f5a33f6b1b55a538.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'libtdegames/carddecks/CMakeLists.txt')
-rw-r--r--libtdegames/carddecks/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/libtdegames/carddecks/CMakeLists.txt b/libtdegames/carddecks/CMakeLists.txt
index 102d0391..6b1bb7fb 100644
--- a/libtdegames/carddecks/CMakeLists.txt
+++ b/libtdegames/carddecks/CMakeLists.txt
@@ -14,4 +14,17 @@ install( DIRECTORY cards-aisleriot cards-dondorf-whist-b
cards-spaced cards-xskat-french cards-default decks
cards-konqi-modern cards-warwick cards-xskat-german
DESTINATION ${DATA_INSTALL_DIR}/carddecks
+ PATTERN *.desktop EXCLUDE
)
+
+file( GLOB_RECURSE _desktops
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/*.desktop )
+foreach( _desktop IN LISTS _desktops )
+ get_filename_component( _theme ${_desktop} PATH )
+ tde_create_translated_desktop(
+ SOURCE ${_desktop}
+ DESTINATION ${DATA_INSTALL_DIR}/carddecks/${_theme}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/libtdegames-carddecks
+ )
+endforeach()