summaryrefslogtreecommitdiffstats
path: root/libtdegames/carddecks/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <[email protected]>2011-11-06 15:56:37 -0600
committerTimothy Pearson <[email protected]>2011-11-06 15:56:37 -0600
commit14c49c4f56792a934bcdc4efceebbd429d858571 (patch)
tree2f302410d5a5d678bf3ff10edead70d348be6644 /libtdegames/carddecks/Makefile.am
parentab0981b9689e4d3ad88e9572bfa4b4a5e36c51ae (diff)
downloadtdegames-14c49c4f56792a934bcdc4efceebbd429d858571.tar.gz
tdegames-14c49c4f56792a934bcdc4efceebbd429d858571.zip
Actually move the kde files that were renamed in the last commit
Diffstat (limited to 'libtdegames/carddecks/Makefile.am')
-rw-r--r--libtdegames/carddecks/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/libtdegames/carddecks/Makefile.am b/libtdegames/carddecks/Makefile.am
new file mode 100644
index 00000000..8effea93
--- /dev/null
+++ b/libtdegames/carddecks/Makefile.am
@@ -0,0 +1,24 @@
+DECKDIRS = cards-aisleriot cards-dondorf-whist-b cards-gdkcard-bonded cards-hard-a-port \
+ cards-penguins cards-spaced cards-xskat-french cards-default decks cards-konqi-modern cards-warwick cards-xskat-german
+
+deckdir = $(kde_datadir)/carddecks
+
+uninstall-local:
+ rm -rf $(DESTDIR)$(deckdir)
+
+install-data-local:
+ @$(mkinstalldirs) $(DESTDIR)$(deckdir)
+ @for i in $(DECKDIRS); do \
+ if test -d $(DESTDIR)$(deckdir)/$$i; then \
+ echo "refreshing and removing $$i" ;\
+ rm -rf $(DESTDIR)$(deckdir)/$$i;\
+ fi ;\
+ echo "installing $$i" ;\
+ mkdir $(DESTDIR)$(deckdir)/$$i ;\
+ files=`cd $(srcdir)/$$i && ls -1d *` ;\
+ for f in $$files; do \
+ if test -f $(srcdir)/$$i/$$f; then \
+ $(INSTALL_DATA) $(srcdir)/$$i/$$f $(DESTDIR)$(deckdir)/$$i/$$f ;\
+ fi \
+ done \
+ done