summaryrefslogtreecommitdiffstats
path: root/kfile-plugins/dependencies/poppler-tqt/CMakeLists.txt
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-07-31 06:24:04 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-07-31 06:24:04 +0000
commit83b9df8edf5bf3eb61e5d2e956695f96500359c1 (patch)
tree0a8ddc5f0c1700cec2aaed2bc3960f08dc7efa4f /kfile-plugins/dependencies/poppler-tqt/CMakeLists.txt
parent56e79472366b958a2ffa31f2cf02cd908d064c8e (diff)
downloadtdegraphics-83b9df8edf5bf3eb61e5d2e956695f96500359c1.tar.gz
tdegraphics-83b9df8edf5bf3eb61e5d2e956695f96500359c1.zip
Fix kdegraphics CMake compilation
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdegraphics@1244149 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kfile-plugins/dependencies/poppler-tqt/CMakeLists.txt')
-rw-r--r--kfile-plugins/dependencies/poppler-tqt/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/kfile-plugins/dependencies/poppler-tqt/CMakeLists.txt b/kfile-plugins/dependencies/poppler-tqt/CMakeLists.txt
new file mode 100644
index 00000000..39984c71
--- /dev/null
+++ b/kfile-plugins/dependencies/poppler-tqt/CMakeLists.txt
@@ -0,0 +1,44 @@
+#################################################
+#
+# (C) 2010-2011 Calvin Morrison
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+project( libpoppler-tqt )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_SOURCE_DIR}/kfile-plugins/dependencies/poppler-tqt
+ /usr/include/poppler
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+##### headers ###################################
+
+install( FILES
+ poppler-qt.h poppler-page-transition.h poppler-link-qt3.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/kde )
+
+##### poppler-tqt (shared) ############################
+
+tde_add_library( poppler-tqt SHARED AUTOMOC
+ SOURCES
+ poppler-document.cc poppler-fontinfo.cc
+ poppler-link.cc poppler-page.cc
+ poppler-page-transition.cc poppler-page-transition-private.h
+ poppler-private.cc poppler-private.h
+ VERSION 0.0.0
+ LINK poppler ${TQT_LIBRARIES}
+ DESTINATION ${LIB_INSTALL_DIR}
+) \ No newline at end of file