summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2021-07-29 15:09:53 +0200
committerSlávek Banko <[email protected]>2021-07-29 15:11:59 +0200
commit16d9625bf33cef60954b9d3cf096b75c3dfa0b13 (patch)
tree6ef734990fc21482fb435f02791a9e8f73b08858 /CMakeLists.txt
parentb7b773b51397f41b9ced02616e57a3e4cd07ffaa (diff)
downloadtdeio-apt-16d9625bf33cef60954b9d3cf096b75c3dfa0b13.tar.gz
tdeio-apt-16d9625bf33cef60954b9d3cf096b75c3dfa0b13.zip
Use common rules for build and install translations.
Change documentation path to tdeioslave/apt. Change CMake project name to tdeio_apt. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit b21b72577a8b227d8980f9ed9611601861ef4bb3)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ce10520..06a320c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,7 +12,7 @@ cmake_minimum_required( VERSION 2.8.12 )
#### general package setup
-project( tdeio-apt )
+project( tdeio_apt )
set( VERSION R14.0.11 )
@@ -68,9 +68,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+##### other data ################################
+
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
+
##### write configure files