summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2019-01-01 13:06:27 +0100
committerSlávek Banko <[email protected]>2019-01-01 19:46:57 +0100
commit79583b3adacd0d3930ecef478a8535a7f4797803 (patch)
tree854b19e9f1b418d7bf643a8338ebcc3d21400a09 /src/CMakeLists.txt
parent4f06bd748c726dacd29cd25eefa1502c835e4ed3 (diff)
downloadtdeio-apt-79583b3adacd0d3930ecef478a8535a7f4797803.tar.gz
tdeio-apt-79583b3adacd0d3930ecef478a8535a7f4797803.zip
conversion to the cmake building system
Signed-off-by: gregory guy <[email protected]> (cherry picked from commit d1629627d4dc41b6235448811009b2cbe5c08f43)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt53
1 files changed, 53 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..4120377
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,53 @@
+add_subdirectory( parsers )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/parsers
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/parsers
+)
+
+
+##### tdeio_apt (kpart)
+
+tde_add_kpart( tdeio_apt AUTOMOC
+
+ SOURCES
+ aptcache.cpp
+ apt.cpp
+ regexps.cpp
+ packagemanager.cpp
+ dpkg.cpp
+ LINK
+ tdecore-shared
+ tdeui-shared
+ parsers-static
+
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data
+
+install(
+ FILES apt.protocol apt+http.protocol
+ DESTINATION ${SERVICES_INSTALL_DIR}
+)
+
+install(
+ FILES tdeio_apt.css tdedeb_logo.png
+ DESTINATION ${DATA_INSTALL_DIR}/tdeio_apt/
+)
+
+install(
+ FILES apt-search.desktop apt-file.desktop apt-files.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/searchproviders
+)