summaryrefslogtreecommitdiffstats
path: root/translations/messages/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-03-24 16:23:35 +0100
committerSlávek Banko <[email protected]>2020-03-24 16:23:54 +0100
commitf0ead56e9d5debcfcb6c860be5116f854aebe8cf (patch)
tree8554578e47e23ee37354099bf417dfd5a1b28a68 /translations/messages/CMakeLists.txt
parentc0fce915d64c89563b0127eb2a05fb2d52b3b8d6 (diff)
downloadtdeio-apt-f0ead56e9d5debcfcb6c860be5116f854aebe8cf.tar.gz
tdeio-apt-f0ead56e9d5debcfcb6c860be5116f854aebe8cf.zip
Move translations to a new directory layout.
Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit fca87ea3f71a712bdec1692e8aee14667191bd86)
Diffstat (limited to 'translations/messages/CMakeLists.txt')
-rw-r--r--translations/messages/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/translations/messages/CMakeLists.txt b/translations/messages/CMakeLists.txt
new file mode 100644
index 0000000..75c89f8
--- /dev/null
+++ b/translations/messages/CMakeLists.txt
@@ -0,0 +1,14 @@
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
+string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
+
+foreach( _po ${po_files} )
+ get_filename_component( _lang ${_po} NAME_WE )
+ if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
+ if( "${_po}" MATCHES "^([^/]*)/.*" )
+ string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
+ else( )
+ set( _component "${PROJECT_NAME}" )
+ endif( )
+ tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
+ endif( )
+endforeach( )