summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..72706c8
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,22 @@
+
+find_package(KDE4 REQUIRED)
+include(KDE4Defaults)
+add_definitions (${QT_DEFINITIONS} ${KDE4_DEFINITIONS})
+include_directories(${KDE4_INCLUDES})
+
+add_subdirectory(doc)
+
+set(kio_man_PART_SRCS kio_gopher.cpp)
+
+kde4_add_plugin(kio_gopher ${kio_man_PART_SRCS})
+
+target_link_libraries(kio_gopher ${KDE4_KIO_LIBS})
+
+install(TARGETS kio_gopher DESTINATION ${PLUGIN_INSTALL_DIR})
+
+install(FILES gopher.protocol DESTINATION ${SERVICES_INSTALL_DIR})
+
+find_package(Msgfmt REQUIRED)
+find_package(Gettext REQUIRED)
+add_subdirectory( po )
+add_subdirectory( doc-translations )