summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..da7c4b2
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,27 @@
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = kio_umountwrapper.h
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(EXTRACTRC) `find . -name \*.ui -o -name \*.rc` > rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kio_umountwrapper.pot
+
+KDE_ICON = AUTO
+
+#########################################################################
+# APPLICATION SECTION
+#########################################################################
+# this is the program that gets installed. it's name is used for all
+# of the other Makefile.am variables
+bin_PROGRAMS = kio_umountwrapper
+
+# the application source, library search path, and link libraries
+kio_umountwrapper_SOURCES = main.cpp kio_umountwrapper.cpp
+kio_umountwrapper_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+kio_umountwrapper_LDADD = $(LIB_KDEUI)
+