summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1628a580d..7c2ff7b72 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1339,6 +1339,20 @@ if( NOT WITH_${DEFAULT_SPELL_CHECKER} )
endif()
+#### Check for libnm ############################
+
+if( WITH_NETWORK_MANAGER_BACKEND )
+ pkg_search_module( LIBNM libnsm )
+ if( NOT LIBNM_FOUND )
+ tde_message_fatal( "Compiling the NetworkManager backend required libnm, but it was not found." )
+ endif( NOT LIBNM_FOUND )
+ pkg_get_variable( NM_VPN_SERVICE_DIR libnm vpnservicedir )
+ if( "${NM_VPN_SERVICE_DIR}" STREQUAL "" )
+ tde_message_fatal( "Unable to read 'vpnservicedir' from libnm pkg-config file." )
+ endif( "${NM_VPN_SERVICE_DIR}" STREQUAL "" )
+endif( WITH_NETWORK_MANAGER_BACKEND )
+
+
##### enable TDEIconLoader debugging ############
if ( WITH_TDEICONLOADER_DEBUG )