summaryrefslogtreecommitdiffstats
path: root/tdeabc/plugins/evolution/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdeabc/plugins/evolution/Makefile.am')
-rw-r--r--tdeabc/plugins/evolution/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/tdeabc/plugins/evolution/Makefile.am b/tdeabc/plugins/evolution/Makefile.am
new file mode 100644
index 000000000..67a5a64b8
--- /dev/null
+++ b/tdeabc/plugins/evolution/Makefile.am
@@ -0,0 +1,19 @@
+INCLUDES = -I$(top_builddir)/tdeabc -I$(top_srcdir)/tdeabc $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = resourceevo.h dbwrapper.h
+
+kde_module_LTLIBRARIES = tdeabc_evo.la
+
+tdeabc_evo_la_SOURCES = dbwrapper.cpp resourceevo.cpp
+
+tdeabc_evo_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+tdeabc_evo_la_LIBADD = ../../../tdeabc/libkabc.la ../../../tdeui/libtdeui.la -ldb ../../../tdeabc/vcardparser/libvcards.la
+
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/tdeabc_evolution.pot
+
+servicedir = $(kde_servicesdir)/tderesources/tdeabc
+service_DATA = evolution.desktop