summaryrefslogtreecommitdiffstats
path: root/kdict/applet/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-07-08 22:39:20 +0200
committerSlávek Banko <[email protected]>2020-07-08 22:39:20 +0200
commitd36d9267539f12fdaa5a0dd18f6285e4a636e1ac (patch)
tree65966d4e78c0529e0e56f8586a7d9c2ae530d336 /kdict/applet/CMakeLists.txt
parent54888da0ae983555ec963c52007c50d49b3c66af (diff)
downloadtdenetwork-d36d9267539f12fdaa5a0dd18f6285e4a636e1ac.tar.gz
tdenetwork-d36d9267539f12fdaa5a0dd18f6285e4a636e1ac.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'kdict/applet/CMakeLists.txt')
-rw-r--r--kdict/applet/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/kdict/applet/CMakeLists.txt b/kdict/applet/CMakeLists.txt
index ad2d6b7d..2b702285 100644
--- a/kdict/applet/CMakeLists.txt
+++ b/kdict/applet/CMakeLists.txt
@@ -22,9 +22,11 @@ link_directories(
##### other data ################################
-install( FILES
- kdictapplet.desktop
- DESTINATION ${DATA_INSTALL_DIR}/kicker/applets )
+tde_create_translated_desktop(
+ SOURCE kdictapplet.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/kicker/applets
+ PO_DIR kdict-desktops
+)
##### kdict_panelapplet (module) ################