summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2019-10-28 17:57:52 +0100
committerSlávek Banko <[email protected]>2019-10-28 17:57:52 +0100
commit1c40516d66c60fa211db7b535f93801802d2ff3e (patch)
treed07c5ae0b7f2e5ddcc5b2bc2b71e6a934bd6a160 /CMakeLists.txt
parentbbe9bf4b3b0f7219a22b84bb64d0f013738b0ae6 (diff)
downloadtdenetworkmanager-1c40516d66c60fa211db7b535f93801802d2ff3e.tar.gz
tdenetworkmanager-1c40516d66c60fa211db7b535f93801802d2ff3e.zip
Add KDE_EXPORT to public library symbols.
This fix build with gcc hidden visibility. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e7798a6..1d31a3b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,7 +48,7 @@ endif( )
##### optional stuff ############################
option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
-option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" OFF )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
option( WITH_OPENVPN "Enable openvpn support" ${WITH_ALL_OPTIONS} )
option( WITH_PPTP "Enable pptp support" ${WITH_ALL_OPTIONS} )
option( WITH_VPNC "Enable vpnc support" ${WITH_ALL_OPTIONS} )