summaryrefslogtreecommitdiffstats
path: root/kpilot/lib/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit460c52653ab0dcca6f19a4f492ed2c5e4e963ab0 (patch)
tree67208f7c145782a7e90b123b982ca78d88cc2c87 /kpilot/lib/Makefile.am
downloadtdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.tar.gz
tdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kpilot/lib/Makefile.am')
-rw-r--r--kpilot/lib/Makefile.am60
1 files changed, 60 insertions, 0 deletions
diff --git a/kpilot/lib/Makefile.am b/kpilot/lib/Makefile.am
new file mode 100644
index 000000000..b2ceadf1f
--- /dev/null
+++ b/kpilot/lib/Makefile.am
@@ -0,0 +1,60 @@
+### Makefile.am for kpilot/lib
+###
+###
+
+METASOURCES = AUTO
+
+INCLUDES = $(PISOCK_INCLUDE) -I$(top_srcdir) $(all_includes)
+
+### If you must get debugging output on a platform where
+### the libs are built without debugging support, define
+### DEBUG_CERR. Define DEBUG to get debugging support anywhere.
+###
+### KDE_CXXFLAGS=-DDEBUG -DDEBUG_CERR
+##KDE_CXXFLAGS=-DNDEBUG -UDEBUG
+##KDE_CXXFLAGS=-DDEBUG
+
+lib_LTLIBRARIES = libkpilot.la
+
+libkpilot_la_SOURCES = kpilotlibSettings.kcfgc \
+ options.cc plugin.cc syncAction.cc \
+ kpilotlink.cc kpilotdevicelink.cc kpilotlocallink.cc \
+ actions.cc actionQueue.cc \
+ pilot.cc \
+ pilotAppInfo.cc pilotRecord.cc pilotDatabase.cc \
+ pilotLocalDatabase.cc pilotSerialDatabase.cc \
+ pilotMemo.cc \
+ pilotAddress.cc \
+ pilotDateEntry.cc \
+ pilotTodoEntry.cc
+
+libkpilot_la_LDFLAGS = $(PISOCK_LDFLAGS) -no-undefined $(all_libraries) $(KDE_EXTRA_RPATH) $(KDE_RPATH)
+libkpilot_la_LIBADD = $(PISOCK_LIB) $(LIB_KDEUI) $(LIB_KABC) $(top_builddir)/libkcal/libkcal.la
+
+kpilotincludedir = $(includedir)/kpilot
+kpilotinclude_HEADERS = \
+ kpilotlink.h kpilotlocallink.h kpilotdevicelink.h \
+ pilot.h \
+ pilotDatabase.h \
+ pilotLinkVersion.h \
+ pilotLocalDatabase.h \
+ pilotRecord.h \
+ pilotSerialDatabase.h \
+ plugin.h \
+ pluginfactory.h \
+ syncAction.h
+
+
+kde_kcfg_DATA = kpilotlib.kcfg
+
+check-local:
+ rm -f FAILED
+ for i in $(srcdir)/*.h ; do \
+ ( echo "#include <kdemacros.h>" ; echo "#include \"$$i\"" ; echo "int main(int argc,char **argv){return 0;}" ) > header-test.cc; \
+ echo "$$i" ; \
+ g++ $(all_includes) -I$(top_builddir) -DQT_THREAD_SUPPORT -c header-test.cc || echo "$$i" >> FAILED; \
+ done
+ test ! -e FAILED
+
+DOXYGEN_REFERENCES=libkcal kdecore
+include $(top_srcdir)/admin/Doxyfile.am