summaryrefslogtreecommitdiffstats
path: root/kpilot/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kpilot/Makefile.am')
-rw-r--r--kpilot/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/kpilot/Makefile.am b/kpilot/Makefile.am
new file mode 100644
index 000000000..e787d42e6
--- /dev/null
+++ b/kpilot/Makefile.am
@@ -0,0 +1,20 @@
+## kdepim/kpilot/Makefile.am
+## (C) 1997 Stephan Kulow
+## Modified by Adriaan de Groot
+
+SUBDIRS = lib kpilot conduits
+
+messages:
+ $(EXTRACTRC) `find . -name "*.rc" -o -name "*.ui"` > rc.cpp
+ $(XGETTEXT) `find . -name "*.cc" -o -name "*.cpp"` -o $(podir)/kpilot.pot
+ -rm -f rc.cpp
+
+DOXYGEN_REFERENCES = kpilot/lib kpilot/kpilot
+include $(top_srcdir)/admin/Doxyfile.am
+
+# Just for the KPilot developers: grab all the strings, for checking.
+devel-pot :
+ extractrc `find . -name "*.rc" -o -name "*.ui"` > /tmp/rc.cpp
+ xgettext -C --keyword=i18n --keyword=I18N_NOOP -o /tmp/kpilot.po \
+ `find . -name "*.cc"` /tmp/rc.cpp
+