summaryrefslogtreecommitdiffstats
path: root/tderadio3/plugins/timecontrol/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <[email protected]>2013-02-01 17:25:34 -0600
committerTimothy Pearson <[email protected]>2013-02-01 17:25:34 -0600
commit48906a623383ab5222541ae048e99dd039b62a9a (patch)
tree1c5f588e90899bb1301f79cf97b8f6ddc0b1c367 /tderadio3/plugins/timecontrol/Makefile.am
parenta1e6ce502c334194d31a0b78b11b77e9532da64b (diff)
downloadtderadio-48906a623383ab5222541ae048e99dd039b62a9a.tar.gz
tderadio-48906a623383ab5222541ae048e99dd039b62a9a.zip
Fix FTBFS
Diffstat (limited to 'tderadio3/plugins/timecontrol/Makefile.am')
-rw-r--r--tderadio3/plugins/timecontrol/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/tderadio3/plugins/timecontrol/Makefile.am b/tderadio3/plugins/timecontrol/Makefile.am
new file mode 100644
index 0000000..0ac954f
--- /dev/null
+++ b/tderadio3/plugins/timecontrol/Makefile.am
@@ -0,0 +1,17 @@
+SUBDIRS = po icons .
+
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+libkradio_LTLIBRARIES = libtimecontrol.la
+libtimecontrol_la_SOURCES = timecontrol-configuration.cpp \
+ timecontrol-configuration-ui.ui timecontrol.cpp
+libtimecontrol_la_LDFLAGS = -module -avoid-version $(KDE_RPATH) $(all_libraries)
+noinst_HEADERS = timecontrol-configuration.h timecontrol.h
+
+#messages: rc.cpp
+# $(XGETTEXT) *.cpp *.h -o po/kradio-timecontrol.pot
+
+messages: rc.cpp
+ $(EXTRACTRC) *.rc *.ui >> rc.cpp
+ $(XGETTEXT) rc.cpp *.h *.cpp -o po/kradio-timecontrol.pot