summaryrefslogtreecommitdiffstats
path: root/kradio3/plugins/timeshifter/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kradio3/plugins/timeshifter/Makefile.am')
-rw-r--r--kradio3/plugins/timeshifter/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/kradio3/plugins/timeshifter/Makefile.am b/kradio3/plugins/timeshifter/Makefile.am
new file mode 100644
index 0000000..23da794
--- /dev/null
+++ b/kradio3/plugins/timeshifter/Makefile.am
@@ -0,0 +1,18 @@
+SUBDIRS = po icons .
+
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+libkradio_LTLIBRARIES = libtimeshifter.la
+libtimeshifter_la_SOURCES = timeshifter.cpp timeshifter-configuration-ui.ui \
+ timeshifter-configuration.cpp
+libtimeshifter_la_LDFLAGS = -module -avoid-version $(KDE_RPATH) $(all_libraries)
+
+noinst_HEADERS = timeshifter.h timeshifter-configuration.h
+
+#messages: rc.cpp
+# $(XGETTEXT) *.cpp *.h -o po/kradio-timeshifter.pot
+
+messages: rc.cpp
+ $(EXTRACTRC) *.rc *.ui >> rc.cpp
+ $(XGETTEXT) rc.cpp *.h *.cpp -o po/kradio-timeshifter.pot