summaryrefslogtreecommitdiffstats
path: root/src/commands/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/commands/Makefile.am')
-rw-r--r--src/commands/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/commands/Makefile.am b/src/commands/Makefile.am
new file mode 100644
index 0000000..95147c2
--- /dev/null
+++ b/src/commands/Makefile.am
@@ -0,0 +1,29 @@
+AM_CPPFLAGS = $(all_includes)
+
+noinst_LIBRARIES = libcommands.a
+libcommands_a_SOURCES = \
+ addentries.cpp modifyentries.cpp removeentries.cpp \
+ addloans.cpp modifyloans.cpp removeloans.cpp \
+ fieldcommand.cpp filtercommand.cpp reorderfields.cpp \
+ group.cpp collectioncommand.cpp renamecollection.cpp \
+ updateentries.cpp
+
+libcommands_a_METASOURCES = AUTO
+KDE_OPTIONS = noautodist
+EXTRA_DIST = \
+ addentries.h addentries.cpp \
+ modifyentries.h modifyentries.cpp \
+ removeentries.h removeentries.cpp \
+ addloans.h addloans.cpp \
+ modifyloans.h modifyloans.cpp \
+ removeloans.h removeloans.cpp \
+ fieldcommand.h fieldcommand.cpp \
+ filtercommand.h filtercommand.cpp \
+ reorderfields.h reorderfields.cpp \
+ group.h group.cpp \
+ collectioncommand.h collectioncommand.cpp \
+ renamecollection.h renamecollection.cpp \
+ updateentries.h updateentries.cpp
+
+
+CLEANFILES = *~