summaryrefslogtreecommitdiffstats
path: root/src/konqplugin/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2020-10-20 14:40:51 +0200
committergregory guy <[email protected]>2021-01-13 18:12:31 +0100
commit81b64bcfc0a32fdeb0e4f367adbf273d924e55f4 (patch)
tree9e0903eb2b5cc19a7dcf4874d098a29133d3163c /src/konqplugin/CMakeLists.txt
parent8b4f72aa0753110a46db9195216f3c88e14a9b69 (diff)
downloadtork-81b64bcfc0a32fdeb0e4f367adbf273d924e55f4.tar.gz
tork-81b64bcfc0a32fdeb0e4f367adbf273d924e55f4.zip
Conversion to the cmake building system.
Signed-off-by: gregory guy <[email protected]>
Diffstat (limited to 'src/konqplugin/CMakeLists.txt')
-rw-r--r--src/konqplugin/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/src/konqplugin/CMakeLists.txt b/src/konqplugin/CMakeLists.txt
new file mode 100644
index 0000000..1da7c27
--- /dev/null
+++ b/src/konqplugin/CMakeLists.txt
@@ -0,0 +1,41 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### tdehtml_tork (kpart)
+
+tde_add_kpart( tdehtml_tork AUTOMOC
+
+ SOURCES
+ tork_plug_in.cpp
+ LINK
+ tdehtml-shared
+
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### icons
+
+tde_install_icons( )
+
+
+##### other data
+
+install(
+ FILES tork_plug_in.rc
+ DESTINATION ${DATA_INSTALL_DIR}/tdehtml/kpartplugins
+)
+
+
+tde_create_translated_desktop( tork_plug_in.desktop )