summaryrefslogtreecommitdiffstats
path: root/src/GeoIP-1.4.0/libGeoIP/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/GeoIP-1.4.0/libGeoIP/CMakeLists.txt')
-rw-r--r--src/GeoIP-1.4.0/libGeoIP/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/GeoIP-1.4.0/libGeoIP/CMakeLists.txt b/src/GeoIP-1.4.0/libGeoIP/CMakeLists.txt
new file mode 100644
index 0000000..a0b9be0
--- /dev/null
+++ b/src/GeoIP-1.4.0/libGeoIP/CMakeLists.txt
@@ -0,0 +1,23 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/src
+ ${ZLIB_INCLUDE_DIRS}
+)
+
+
+##### geoip (static)
+
+tde_add_library( geoip STATIC_PIC
+
+ SOURCES
+ GeoIP.c
+ GeoIPCity.c
+ regionName.c
+ timeZone.c
+ GeoIPUpdate.c
+ md5.c
+ LINK
+ ${ZLIB_LIBRARIES}
+)