summaryrefslogtreecommitdiffstats
path: root/src/GeoIP-1.4.0/libGeoIP/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/GeoIP-1.4.0/libGeoIP/Makefile.am')
-rw-r--r--src/GeoIP-1.4.0/libGeoIP/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/GeoIP-1.4.0/libGeoIP/Makefile.am b/src/GeoIP-1.4.0/libGeoIP/Makefile.am
new file mode 100644
index 0000000..fdecb0a
--- /dev/null
+++ b/src/GeoIP-1.4.0/libGeoIP/Makefile.am
@@ -0,0 +1,17 @@
+noinst_LTLIBRARIES = libGeoIP.la libGeoIPUpdate.la
+
+EXTRA_DIST = md5.h global.h types.h GeoIP_internal.h
+
+AM_CPPFLAGS = -DGEOIPDATADIR=\"$(pkgdatadir)\" -Wall
+
+if WITH_CITY
+libGeoIP_la_SOURCES = GeoIP.c GeoIPCity.c regionName.c timeZone.c
+else
+libGeoIP_la_SOURCES = GeoIP.c regionName.c timeZone.c
+endif
+
+libGeoIPUpdate_la_SOURCES = GeoIPUpdate.c md5.c
+
+#libGeoIP_la_LDFLAGS = -version-info @GEOIP_VERSION_INFO@
+
+libGeoIPUpdate_la_LIBADD = -lz libGeoIP.la