summaryrefslogtreecommitdiffstats
path: root/qtinterface/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'qtinterface/CMakeLists.txt')
-rw-r--r--qtinterface/CMakeLists.txt11
1 files changed, 2 insertions, 9 deletions
diff --git a/qtinterface/CMakeLists.txt b/qtinterface/CMakeLists.txt
index 9ab1e4a..d0eaf8d 100644
--- a/qtinterface/CMakeLists.txt
+++ b/qtinterface/CMakeLists.txt
@@ -27,15 +27,10 @@ link_directories(
${TQT_LIBRARY_DIR}
)
-if ( INPUTMETHOD_ENABLED )
- set( INPUTMETHOD_HEADERS ${IFACE}/tqinputcontext.h ${IFACE}/tqinputcontextfactory.h ${IFACE}/tqinputcontextplugin.h )
-endif()
-
##### headers ###################################
install( FILES
${IFACE}/tqapplication.h
- ${IFACE}/tqinputdialog.h
${IFACE}/tqmessagebox.h
${IFACE}/tqnp.h
${IFACE}/tqprintdialog.h
@@ -43,10 +38,9 @@ install( FILES
${IFACE}/tqsound.h ${IFACE}/tqsplashscreen.h
${IFACE}/tqsplitter.h
${IFACE}/tqconfig.h
- ${IFACE}/tqjpegio.h ${IFACE}/tqkeycode.h ${IFACE}/tqmngio.h ${IFACE}/tqmodules.h
+ ${IFACE}/tqmngio.h ${IFACE}/tqmodules.h
${IFACE}/tqwindowdefs.h ${IFACE}/tqwinexport.h
- ${IFACE}/tqjpunicode.h ${IFACE}/tqkeysequence.h
- ${IFACE}/tqlibrary.h ${IFACE}/tqmetaobject.h
+ ${IFACE}/tqmetaobject.h
${IFACE}/tqnamespace.h
${IFACE}/tqpolygonscanner.h
${IFACE}/tqshared.h
@@ -57,7 +51,6 @@ install( FILES
${IFACE}/private/tqinternal_p.h ${IFACE}/private/tqeffects_p.h
${IFACE}/private/tqrichtext_p.h ${IFACE}/private/tqpluginmanager_p.h ${IFACE}/private/tqcom_p.h
${IFACE}/private/tqucom_p.h
- ${INPUTMETHOD_HEADERS}
DESTINATION ${INCLUDE_INSTALL_DIR} )
##### tqt tools #################################