summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2021-07-12 19:30:23 +0200
committerSlávek Banko <[email protected]>2021-07-12 19:44:58 +0200
commit7d5c09fcba81401f990f6ec9f9b53f9f0f92ca9e (patch)
treef0bb2ca42d7105c8d585d9bdd747ba2b67ed099a /CMakeLists.txt
parent402e7a479aeff06fef928520f6c4d70c31d74694 (diff)
downloadtwin-style-dekorator-7d5c09fcba81401f990f6ec9f9b53f9f0f92ca9e.tar.gz
twin-style-dekorator-7d5c09fcba81401f990f6ec9f9b53f9f0f92ca9e.zip
Add KDE_EXPORT to the public symbols.
Add twin client translations into template. Use common rules for build and install translations. Delete generated files. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b647309..7b948ef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,6 +45,12 @@ option( WITH_ALL_OPTIONS "Enable all optional support" OFF
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+##### user requested modules
+
+option( BUILD_ALL "Build all" ON )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+
+
##### configure checks
include( ConfigureChecks.cmake )
@@ -64,7 +70,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
add_subdirectory( client )
add_subdirectory( themes )
+
+##### other data
+
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
+
+
##### write configure files
configure_file( config.h.cmake config.h @ONLY )
-