summaryrefslogtreecommitdiffstats
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'client/CMakeLists.txt')
-rw-r--r--client/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
new file mode 100644
index 0000000..e7755f4
--- /dev/null
+++ b/client/CMakeLists.txt
@@ -0,0 +1,41 @@
+tde_import( twin )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIBRARY_DIRS}
+)
+
+
+add_subdirectory( pics )
+
+
+##### twin_fahrenheit (kpart)
+
+tde_add_kpart( twin_fahrenheit AUTOMOC
+
+ SOURCES
+ fahrenheitclient.cc
+ fahrenheitclient.h
+ LINK
+ tdecore-shared
+ tdeui-shared
+ tdecorations-shared
+
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data
+
+tde_create_translated_desktop(
+ SOURCE fahrenheit.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/twin
+)