summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMavridis Philippe <[email protected]>2021-06-27 11:12:50 +0300
committerMavridis Philippe <[email protected]>2021-06-27 12:12:35 +0300
commit7d07debf70de7043e91439dd14918e66a4a36be6 (patch)
tree11a6a8a8f92fd3e7e54dbc30cb4056ba25311598 /CMakeLists.txt
parent66638dbefa4105fc0ac4e4a8662f7e5a449e3789 (diff)
downloadtwin-style-suse2-7d07debf70de7043e91439dd14918e66a4a36be6.tar.gz
twin-style-suse2-7d07debf70de7043e91439dd14918e66a4a36be6.zip
Various L10n fixes
* Removed old POT file * Fixed TDEGlobal->locale()->insertCatalogue() to use new file naming Signed-off-by: Mavridis Philippe <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 188cffb..8fc4fca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,6 +39,12 @@ include( TDESetupPaths )
tde_setup_paths( )
+##### user-requested modules
+
+option( BUILD_ALL "Build all" ON )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+
+
##### optional stuff
option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
@@ -63,7 +69,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
add_subdirectory( src )
add_subdirectory( extra )
-add_subdirectory( translations )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files