summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2023-10-30 11:47:01 +0900
committerMichele Calgaro <[email protected]>2023-10-30 11:47:01 +0900
commitd54efa8cb872b6ecc7657dd215efeeabf04821e1 (patch)
treed177cc3a032282804cbcf4c3d06dea10cfce59b0 /src/CMakeLists.txt
parentc0b1f3384ccc4dbf9311e97829f9218cf944fac8 (diff)
downloaduniversal-indent-gui-tqt-d54efa8cb872b6ecc7657dd215efeeabf04821e1.tar.gz
universal-indent-gui-tqt-d54efa8cb872b6ecc7657dd215efeeabf04821e1.zip
Add git hash to program version
Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt51
1 files changed, 25 insertions, 26 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 84845f3..1744c4a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -7,9 +7,9 @@
#################################################
include_directories(
- ${CMAKE_CURRENT_SOURCE_DIR}
- ${CMAKE_CURRENT_BINARY_DIR}
- ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
${TQT_INCLUDE_DIRS}
)
@@ -26,31 +26,30 @@ link_directories(
set( target universal-indent-gui-tqt )
set( ${target}_SRCS
- # completed
- MainWindowBase.ui
- ToolBarWidget.ui
-
- IndentHandler.cpp
- SettingsPaths.cpp
- TemplateBatchScript.cpp
- UiGuiErrorMessage.cpp
- UiGuiHighlighter.cpp
- UiGuiIniFileParser.cpp
- UiGuiVersion.cpp
-
- # ongoing
- AboutDialogBase.ui
- UiGuiSettingsDialogBase.ui
-
- AboutDialog.cpp
- MainWindow.cpp
- main.cpp
- UiGuiSettings.cpp
- UiGuiSettingsDialog.cpp
+ # completed
+ MainWindowBase.ui
+ ToolBarWidget.ui
+
+ IndentHandler.cpp
+ SettingsPaths.cpp
+ TemplateBatchScript.cpp
+ UiGuiErrorMessage.cpp
+ UiGuiHighlighter.cpp
+ UiGuiIniFileParser.cpp
+
+ # ongoing
+ AboutDialogBase.ui
+ UiGuiSettingsDialogBase.ui
+
+ AboutDialog.cpp
+ MainWindow.cpp
+ main.cpp
+ UiGuiSettings.cpp
+ UiGuiSettingsDialog.cpp
)
tde_add_executable( ${target} AUTOMOC
SOURCES ${${target}_SRCS}
- LINK ${TQT_LIBRARIES} ${TQSCINTILLA_LIBRARIES}
- DESTINATION ${BIN_INSTALL_DIR}
+ LINK ${TQT_LIBRARIES} ${TQSCINTILLA_LIBRARIES}
+ DESTINATION ${BIN_INSTALL_DIR}
)