summaryrefslogtreecommitdiffstats
path: root/indenters/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indenters/CMakeLists.txt')
-rw-r--r--indenters/CMakeLists.txt34
1 files changed, 8 insertions, 26 deletions
diff --git a/indenters/CMakeLists.txt b/indenters/CMakeLists.txt
index 2fc3cb0..b5062c9 100644
--- a/indenters/CMakeLists.txt
+++ b/indenters/CMakeLists.txt
@@ -1,29 +1,11 @@
+file( GLOB _indenters RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.ini *.cpp)
install(
- FILES
- example.cpp
- uigui_astyle.ini
- uigui_bcpp.ini
- uigui_CblBeau.ini
- uigui_csstidy.ini
- uigui_f90ppr.ini
- uigui_gnuindent.ini
- uigui_greatcode.ini
- uigui_hindent.ini
- uigui_htb.ini
- uigui_jsdecoder.ini
- uigui_jsppp.ini
- uigui_perltidy.ini
- uigui_php_Beautifier.ini
- uigui_phpCB.ini
- uigui_phpStylist.ini
- uigui_pindent.ini
- uigui_psti.ini
- uigui_rbeautify.ini
- uigui_rubyformatter.ini
- uigui_shellindent.ini
- uigui_tidy.ini
- uigui_uncrustify.ini
- uigui_vbsbeaut.ini
- uigui_xmlindent.ini
+ FILES ${_indenters}
DESTINATION ${SHARE_INSTALL_PREFIX}/universal-indent-gui-tqt/indenters
)
+
+file( GLOB _indenters_examples RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} examples/* )
+install(
+ FILES ${_indenters_examples}
+ DESTINATION ${SHARE_INSTALL_PREFIX}/universal-indent-gui-tqt/indenters/examples
+)