summaryrefslogtreecommitdiffstats
path: root/translations/messages/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-05-10 19:09:41 +0200
committerSlávek Banko <[email protected]>2020-05-10 19:09:50 +0200
commitad6b015ae5d8c748d6f965ab2a43745c63c333dc (patch)
tree0888a7eb8c837065eb6e9a0084eb685372dd7152 /translations/messages/CMakeLists.txt
parent06a83f5f346015b0e2e8066008b7be32fc253831 (diff)
downloadwlassistant-ad6b015ae5d8c748d6f965ab2a43745c63c333dc.tar.gz
wlassistant-ad6b015ae5d8c748d6f965ab2a43745c63c333dc.zip
Move translations to a new directory layout.
Add support for LINGUAS for listing translations to install. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 44c7a77fbd61674a355d3051d62fcf68e5ce82db)
Diffstat (limited to 'translations/messages/CMakeLists.txt')
-rw-r--r--translations/messages/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/translations/messages/CMakeLists.txt b/translations/messages/CMakeLists.txt
new file mode 100644
index 0000000..75c89f8
--- /dev/null
+++ b/translations/messages/CMakeLists.txt
@@ -0,0 +1,14 @@
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
+string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
+
+foreach( _po ${po_files} )
+ get_filename_component( _lang ${_po} NAME_WE )
+ if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
+ if( "${_po}" MATCHES "^([^/]*)/.*" )
+ string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
+ else( )
+ set( _component "${PROJECT_NAME}" )
+ endif( )
+ tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
+ endif( )
+endforeach( )