summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEmanoil Kotsev <[email protected]>2024-07-11 23:13:01 +0000
committerEmanoil Kotsev <[email protected]>2024-07-11 23:13:01 +0000
commitfa084fcf0267031321a692022c8da1022167ebed (patch)
treec8c330654b5c0d06050de2b3f0b07f7c84a86b93 /CMakeLists.txt
parentae92cf1205676d2ff0c344b2a1305e546d5dd0a5 (diff)
downloadxdg-desktop-portal-tde-fa084fcf0267031321a692022c8da1022167ebed.tar.gz
xdg-desktop-portal-tde-fa084fcf0267031321a692022c8da1022167ebed.zip
reworked and created the structure for the complete interface implementation
Note: this is only the structure of the interface Signed-off-by: Emanoil Kotsev <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9c6cd02..bc6e4da 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,7 +6,12 @@
# This software is licensed under the terms of the GNU GPL v3 license. #
################################################################################
-cmake_minimum_required( VERSION 3.1 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+
+#### general package setup
project( xdg-desktop-portal-tde )