summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-03-15 11:10:00 +0900
committerMichele Calgaro <[email protected]>2024-03-17 15:40:02 +0900
commit35bbdf5e477a6eceeea52cb4d40b9f11698736a0 (patch)
treec7a4c80bedcd1df79b2395718fbaf6d4208a8fe3 /CMakeLists.txt
parent9e7f45da0cf8d3e505f8bfa7e801da01e117879b (diff)
downloadyakuake-35bbdf5e477a6eceeea52cb4d40b9f11698736a0.tar.gz
yakuake-35bbdf5e477a6eceeea52cb4d40b9f11698736a0.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <[email protected]> (cherry picked from commit 0a6d1be49ac88a82ac5a0bbfbaeff366c8d2998d)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9c31356..6a9a349 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -30,11 +34,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )