summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2021-06-17 10:32:53 +0200
committerSlávek Banko <[email protected]>2021-06-17 10:32:53 +0200
commit6b1d512016b9580744f8367cc85ac08d173e1bd7 (patch)
treedc3a878e79e97263f24a2c1ed385f1c70f0d78dc /CMakeLists.txt
parent8e3bd36521469a034d667855967bb847efb4360e (diff)
downloadabakus-6b1d512016b9580744f8367cc85ac08d173e1bd7.tar.gz
abakus-6b1d512016b9580744f8367cc85ac08d173e1bd7.zip
Update to use tde_conditional_add_project_… rules
for documentation and translations. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d9b6247..f7c08c8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -68,8 +68,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
add_subdirectory( icons )
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files #####################