summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2021-06-17 10:32:53 +0200
committerSlávek Banko <[email protected]>2021-06-17 10:33:07 +0200
commitb1f604964ecde7258e653df124883c61494f6c20 (patch)
tree929e7488272636e35c852e67ffa32fc9fd25e027 /CMakeLists.txt
parent12997bc5337a6be3019dccdc0a9ad9b53b3e9223 (diff)
downloadabakus-b1f604964ecde7258e653df124883c61494f6c20.tar.gz
abakus-b1f604964ecde7258e653df124883c61494f6c20.zip
Update to use tde_conditional_add_project_… rules
for documentation and translations. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 6b1d512016b9580744f8367cc85ac08d173e1bd7)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d9b6247..f7c08c8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -68,8 +68,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
add_subdirectory( icons )
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files #####################