summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <[email protected]>2011-11-27 20:25:58 -0600
committerSlávek Banko <[email protected]>2012-07-29 19:24:38 +0200
commit8a2e76e9d039c7738c33f18f25342084f7458e5c (patch)
tree7854749de2f9d37bf44aa052f1a0d72df96981d9 /src/CMakeLists.txt
parent0350ba0db07237305a0a682fd7ecc5d78587be84 (diff)
downloadabakus-8a2e76e9d039c7738c33f18f25342084f7458e5c.tar.gz
abakus-8a2e76e9d039c7738c33f18f25342084f7458e5c.zip
Initial conversion to standard CMake system
(cherry picked from commit b939a1459ef0e4eec6d8dd111baf8e022d1b46a0)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt49
1 files changed, 49 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..e9581b3
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,49 @@
+#################################################
+#
+# (C) 2011 Timothy Pearson
+# kb9vqf (AT) pearsoncomputing.net
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/src
+ ${CMAKE_SOURCE_DIR}/src
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES abakus.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+install( FILES abakusui.rc DESTINATION ${DATA_INSTALL_DIR} )
+
+##### abakus (executable) #######################
+
+if( HAVE_MPFR )
+ MPFR_SOURCES="hmath.cpp number.c"
+ MPFR_LIBRARIES="mpfr gmp"
+endif( HAVE_MPFR )
+
+tde_add_executable( abakus AUTOMOC
+ SOURCES abakus.cpp abakuslistview.cpp
+ dragsupport.cpp editor.cpp
+ evaluator.cpp function.cpp
+ lexer_lex.cpp mainwindow.cpp
+ node.cpp numerictypes.cpp
+ parser_yacc.cpp result.cpp
+ resultlistview.cpp resultlistviewtext.cpp
+ rpnmuncher.cpp valuemanager.cpp dcopIface.skel
+ ${MPFR_SOURCES}
+ LINK kio-shared kdecore-shared kdeprint-shared kdeui-shared DCOP-shared ${MPFR_LIBRARIES}
+ DESTINATION ${BIN_INSTALL_DIR}
+)