summaryrefslogtreecommitdiffstats
path: root/translations/messages/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2021-06-07 01:08:40 +0200
committerSlávek Banko <[email protected]>2021-06-07 01:08:52 +0200
commit12997bc5337a6be3019dccdc0a9ad9b53b3e9223 (patch)
tree0de40d255de3d13d92b5ff5f4c8a66ca9fa8d5b5 /translations/messages/CMakeLists.txt
parentcc47e243011daa9cfbd3cda727993540793caa20 (diff)
downloadabakus-12997bc5337a6be3019dccdc0a9ad9b53b3e9223.tar.gz
abakus-12997bc5337a6be3019dccdc0a9ad9b53b3e9223.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 8e3bd36521469a034d667855967bb847efb4360e)
Diffstat (limited to 'translations/messages/CMakeLists.txt')
-rw-r--r--translations/messages/CMakeLists.txt15
1 files changed, 1 insertions, 14 deletions
diff --git a/translations/messages/CMakeLists.txt b/translations/messages/CMakeLists.txt
index 75c89f8..24e3bd8 100644
--- a/translations/messages/CMakeLists.txt
+++ b/translations/messages/CMakeLists.txt
@@ -1,14 +1 @@
-file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
-string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
-
-foreach( _po ${po_files} )
- get_filename_component( _lang ${_po} NAME_WE )
- if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
- if( "${_po}" MATCHES "^([^/]*)/.*" )
- string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
- else( )
- set( _component "${PROJECT_NAME}" )
- endif( )
- tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
- endif( )
-endforeach( )
+tde_add_project_translations()