summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2019-01-29 12:40:35 +0100
committerSlávek Banko <[email protected]>2019-02-02 16:20:19 +0100
commit515b5e3a1353a17b2eb504ab33e240abb925f0ef (patch)
tree11dfc1be2a6dbf6886ea5ed9d22bd372b796abc1 /CMakeLists.txt
parent79aff3b728779e4fd2c12e0915eb461c91916d12 (diff)
downloadakode-515b5e3a1353a17b2eb504ab33e240abb925f0ef.tar.gz
akode-515b5e3a1353a17b2eb504ab33e240abb925f0ef.zip
Update CMake rules
+ Add WITH_GCC_VISIBILITY option + Use common tde_setup_gcc_visibility + Add TestBigEndian and tde_setup_largefiles Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit b0c2717fd80109aa418e75298d66b6053fc6666e)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 97fc164..43666c1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
#################################################
#
-# (C) 2015 Slávek Banko
+# (C) 2015-2019 Slávek Banko
# slavek (DOT) banko (AT) axis.cz
#
# Improvements and feedback are welcome
@@ -24,6 +24,7 @@ set( VERSION R14.0.5 )
include( FindPkgConfig )
include( CheckCXXSourceCompiles )
include( CheckFunctionExists )
+include( CheckSymbolExists )
include( CheckIncludeFile )
include( CheckLibraryExists )
@@ -32,7 +33,6 @@ include( CheckLibraryExists )
set( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )
include( TDEMacros )
-tde_setup_architecture_flags( )
##### setup install paths #######################
@@ -45,6 +45,7 @@ tde_setup_paths( )
option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
OPTION( WITH_LIBLTDL "Build with libltdl" ${WITH_ALL_OPTIONS} )
OPTION( WITH_ALSA_SINK "Build with alsa sink" ${WITH_ALL_OPTIONS} )