summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt73
1 files changed, 73 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..f8e2d94
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,73 @@
+#################################################
+#
+# (C) 2015 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+cmake_minimum_required( VERSION 2.6 )
+
+
+##### general package setup #####################
+
+project( akode )
+set( PACKAGE akode )
+set( VERSION 2.0.2 )
+
+
+##### include essential cmake modules ###########
+
+include( FindPkgConfig )
+include( CheckCXXSourceCompiles )
+include( CheckFunctionExists )
+include( CheckIncludeFile )
+include( CheckLibraryExists )
+
+
+##### include our cmake modules #################
+
+set( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )
+include( TDEMacros )
+tde_setup_architecture_flags( )
+
+
+##### setup install paths #######################
+
+include( TDESetupPaths )
+tde_setup_paths( )
+
+
+##### optional stuff ############################
+
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+
+OPTION( WITH_LIBLTDL "Build with libltdl" ${WITH_ALL_OPTIONS} )
+
+OPTION( WITH_ALSA_SINK "Build with alsa sink" ${WITH_ALL_OPTIONS} )
+OPTION( WITH_JACK_SINK "Build with jack sink" ${WITH_ALL_OPTIONS} )
+OPTION( WITH_POLYP_SINK "Build with polyp sink" OFF )
+OPTION( WITH_OSS_SINK "Build with oss sink" ${WITH_ALL_OPTIONS} )
+OPTION( WITH_SUN_SINK "Build with sun sink" OFF )
+
+OPTION( WITH_FFMPEG_DECODER "Build with ffmeeg decoder" OFF )
+option( WITH_MPC_DECODER "Build with mpc decoder" ON )
+option( WITH_MPEG_DECODER "Build with mpeg decoder" ${WITH_ALL_OPTIONS} )
+OPTION( WITH_SRC_RESAMPLER "Build with src resampler" ${WITH_ALL_OPTIONS} )
+option( WITH_XIPH_DECODER "Build with xiph decoder" ${WITH_ALL_OPTIONS} )
+
+
+##### configure checks ##########################
+
+include( ConfigureChecks.cmake )
+add_definitions( -DHAVE_CONFIG_H )
+configure_file( config.h.cmake config.h @ONLY )
+
+
+##### build #####################################
+
+tde_auto_add_subdirectories()
+