summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-03-15 10:58:44 +0900
committerMichele Calgaro <[email protected]>2024-03-17 11:08:56 +0900
commitc775bd9997560358c1ab3e4ae228635efa94f4ce (patch)
treee52148451deb734a220b1b16d419f5691527c222 /CMakeLists.txt
parente6e3ba968971633b652e27aa29907d37785eaf52 (diff)
downloadamarok-c775bd9997560358c1ab3e4ae228635efa94f4ce.tar.gz
amarok-c775bd9997560358c1ab3e4ae228635efa94f4ce.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0d4a9565..238bbfd7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,7 +9,12 @@
#
#################################################
-cmake_minimum_required( VERSION 3.5 )
+
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
##### general package setup #####################
@@ -33,11 +38,6 @@ include( FindPkgConfig )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths #######################
include( TDESetupPaths )