summaryrefslogtreecommitdiffstats
path: root/mcop/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'mcop/CMakeLists.txt')
-rw-r--r--mcop/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/mcop/CMakeLists.txt b/mcop/CMakeLists.txt
index fe62f9f..7b4eec1 100644
--- a/mcop/CMakeLists.txt
+++ b/mcop/CMakeLists.txt
@@ -12,11 +12,11 @@
configure_file( arts_export.h.in arts_export.h )
if( NOT EXTENSION_DIR )
- set( EXTENSION_DIR ${CMAKE_INSTALL_PREFIX}/lib )
+ set( EXTENSION_DIR ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX} )
endif( NOT EXTENSION_DIR )
if( NOT DTRADER_DIR )
- set( DTRADER_DIR ${CMAKE_INSTALL_PREFIX}/lib/mcop )
+ set( DTRADER_DIR ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}/mcop )
endif( NOT DTRADER_DIR )
add_definitions(
@@ -66,6 +66,6 @@ set( ${target}_SRCS
tde_add_library( ${target} SHARED
SOURCES ${${target}_SRCS}
VERSION 1.0.0
- LINK ltdlc-static
+ LINK ltdlc-static ${ESOUND_LIBRARIES}
DESTINATION ${LIB_INSTALL_DIR}
)