summaryrefslogtreecommitdiffstats
path: root/mcop_mt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'mcop_mt/CMakeLists.txt')
-rw-r--r--mcop_mt/CMakeLists.txt16
1 files changed, 11 insertions, 5 deletions
diff --git a/mcop_mt/CMakeLists.txt b/mcop_mt/CMakeLists.txt
index 09fed8c..d3cd471 100644
--- a/mcop_mt/CMakeLists.txt
+++ b/mcop_mt/CMakeLists.txt
@@ -9,10 +9,16 @@
#
#################################################
-set( mcop_mt_SRCS
- threads_posix.cc
+include_directories(
+ ${CMAKE_BINARY_DIR}
)
-add_library( mcop_mt SHARED ${mcop_mt_SRCS} )
-set_target_properties( mcop_mt PROPERTIES VERSION 1.0 SOVERSION 1 )
-target_link_libraries( mcop_mt mcop artsflow )
+
+##### mcop_mt (shared lib ) #####################
+
+tde_add_library( mcop_mt SHARED
+ SOURCES threads_posix.cc
+ VERSION 1.0.0
+ LINK artsflow-shared
+ DESTINATION ${LIB_INSTALL_DIR}
+)