summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2020-11-22 12:40:16 +0800
committerMichele Calgaro <[email protected]>2020-11-22 12:40:16 +0800
commit4dff79a1b535a2be7f8cb49978ecabcef6532cd0 (patch)
treed8daf0a218e6bc3e708c56b7df669cd10996def8 /po/CMakeLists.txt
parente38ea96cfb38fdccc1d106d5ee4bc52db414a380 (diff)
downloadbasket-4dff79a1b535a2be7f8cb49978ecabcef6532cd0.tar.gz
basket-4dff79a1b535a2be7f8cb49978ecabcef6532cd0.zip
Removed original 'po' translation folder.
Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt14
1 files changed, 0 insertions, 14 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
deleted file mode 100644
index 75c89f8..0000000
--- a/po/CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
-file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
-string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
-
-foreach( _po ${po_files} )
- get_filename_component( _lang ${_po} NAME_WE )
- if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
- if( "${_po}" MATCHES "^([^/]*)/.*" )
- string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
- else( )
- set( _component "${PROJECT_NAME}" )
- endif( )
- tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
- endif( )
-endforeach( )