summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2019-01-30 09:22:58 +0100
committerSlávek Banko <[email protected]>2019-02-02 16:31:34 +0100
commitfd69253f814bb5355b2e2367433cff6a707f995e (patch)
treeea938c5b367feaab22ff0974d40dd3ec27699494 /CMakeLists.txt
parent192f1bc32ccda8e35e9d894661c92cd73e315138 (diff)
downloaddbus-1-tqt-fd69253f814bb5355b2e2367433cff6a707f995e.tar.gz
dbus-1-tqt-fd69253f814bb5355b2e2367433cff6a707f995e.zip
Update CMake rules
+ Add WITH_GCC_VISIBILITY option + Use common tde_setup_gcc_visibility + Add TestBigEndian and tde_setup_largefiles Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit e20e503a96778a72aa3afdc6153eb68d10dc6782)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 90a841b..66f5cb6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,9 +18,20 @@ cmake_minimum_required( VERSION 2.8 )
include( FindPkgConfig )
include( CheckCXXSourceCompiles )
+include( CheckSymbolExists )
set( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )
include( TDEMacros )
+
+
+##### optional stuff
+
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+
+
+##### configure checks ##########################
+
include( ConfigureChecks.cmake )