summaryrefslogtreecommitdiffstats
path: root/src/libs/curves/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libs/curves/Makefile.am')
-rw-r--r--src/libs/curves/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/libs/curves/Makefile.am b/src/libs/curves/Makefile.am
new file mode 100644
index 00000000..f183fcc7
--- /dev/null
+++ b/src/libs/curves/Makefile.am
@@ -0,0 +1,16 @@
+METASOURCES = AUTO
+
+noinst_LTLIBRARIES = libcurves.la
+
+libcurves_la_SOURCES = imagecurves.cpp
+
+libcurves_la_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_TQT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_TDEIO) -ltdetexteditor
+
+INCLUDES = -I$(top_srcdir)/src/libs/histogram \
+ -I$(top_srcdir)/src/libs/dimg \
+ -I$(top_srcdir)/src/digikam \
+ $(all_includes)
+
+digikaminclude_HEADERS = imagecurves.h
+
+digikamincludedir = $(includedir)/digikam