summaryrefslogtreecommitdiffstats
path: root/src/libs/dialogs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libs/dialogs/Makefile.am')
-rw-r--r--src/libs/dialogs/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/libs/dialogs/Makefile.am b/src/libs/dialogs/Makefile.am
new file mode 100644
index 00000000..19d50423
--- /dev/null
+++ b/src/libs/dialogs/Makefile.am
@@ -0,0 +1,33 @@
+METASOURCES = AUTO
+
+noinst_LTLIBRARIES = libdialog.la libdialogshowfoto.la
+
+# Dialogs collection used by Showfoto.
+
+libdialogshowfoto_la_SOURCES = iccprofileinfodlg.cpp imagedialog.cpp rawcameradlg.cpp
+
+libdialogshowfoto_la_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_TQT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_TDEIO) -ltdetexteditor
+
+# Dialogs collection used by digiKam.
+
+libdialog_la_SOURCES = deletedialogbase.ui imagedialog.cpp rawcameradlg.cpp \
+ iccprofileinfodlg.cpp deletedialog.cpp dprogressdlg.cpp
+
+libdialog_la_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_TQT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_TDEIO) -ltdetexteditor
+
+INCLUDES = -I$(top_srcdir)/src/digikam \
+ -I$(top_srcdir)/src/libs/dimg \
+ -I$(top_srcdir)/src/libs/dmetadata \
+ -I$(top_srcdir)/src/libs/thumbbar \
+ -I$(top_srcdir)/src/libs/dimg/filters \
+ -I$(top_srcdir)/src/libs/widgets/common \
+ -I$(top_srcdir)/src/libs/widgets/metadata \
+ -I$(top_srcdir)/src/libs/widgets/iccprofiles \
+ -I$(top_srcdir)/src/libs/widgets/imageplugins \
+ -I$(top_srcdir)/src/utilities/imageeditor/canvas \
+ $(LIBKDCRAW_CFLAGS) \
+ $(LIBKEXIV2_CFLAGS) \
+ $(all_includes)
+
+digikaminclude_HEADERS = iccprofileinfodlg.h dprogressdlg.h imagedialog.h rawcameradlg.h
+digikamincludedir = $(includedir)/digikam