summaryrefslogtreecommitdiffstats
path: root/src/showfoto/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/showfoto/Makefile.am')
-rw-r--r--src/showfoto/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/showfoto/Makefile.am b/src/showfoto/Makefile.am
new file mode 100644
index 00000000..9f5f5064
--- /dev/null
+++ b/src/showfoto/Makefile.am
@@ -0,0 +1,42 @@
+SUBDIRS = setup
+
+METASOURCES = AUTO
+
+bin_PROGRAMS = showfoto
+
+INCLUDES = -I$(top_srcdir)/src/showfoto/setup \
+ -I$(top_srcdir)/src/utilities/setup \
+ -I$(top_srcdir)/src/libs/thumbbar \
+ -I$(top_srcdir)/src/libs/widgets/common \
+ -I$(top_srcdir)/src/libs/imageproperties \
+ -I$(top_srcdir)/src/libs/histogram \
+ -I$(top_srcdir)/src/libs/dimg \
+ -I$(top_srcdir)/src/libs/dmetadata \
+ -I$(top_srcdir)/src/libs/threadimageio \
+ -I$(top_srcdir)/src/libs/themeengine \
+ -I$(top_srcdir)/src/libs/dialogs \
+ -I$(top_srcdir)/src/digikam \
+ -I$(top_srcdir)/src/utilities/slideshow \
+ -I$(top_srcdir)/src/utilities/imageeditor/canvas \
+ -I$(top_srcdir)/src/utilities/imageeditor/editor \
+ -I$(top_srcdir)/src/utilities/imageeditor/tools \
+ $(LIBKEXIV2_CFLAGS) $(LIBKDCRAW_CFLAGS) $(all_includes)
+
+showfoto_SOURCES = main.cpp showfoto.cpp
+
+showfoto_LDADD = $(top_builddir)/src/showfoto/setup/libsetup.la \
+ $(top_builddir)/src/libs/imageproperties/libimagepropertiesshowfoto.la \
+ $(top_builddir)/src/libs/thumbbar/libthumbbar.la \
+ $(top_builddir)/src/utilities/imageeditor/editor/libshowfoto.la \
+ $(top_builddir)/src/utilities/slideshow/libslideshow.la \
+ $(top_builddir)/src/libs/threadimageio/libthreadimageio.la \
+ $(top_builddir)/src/libs/themeengine/libthemeengine.la \
+ $(top_builddir)/src/libs/jpegutils/libjpegutils.la \
+ $(LIB_TDEUTILS) $(LIB_TDEPARTS) $(LIBJPEG)
+
+showfoto_LDFLAGS = $(LIBKEXIV2_LIBS) $(LIBKDCRAW_LIBS) $(KDE_RPATH) $(all_libraries)
+
+rcdir = $(kde_datadir)/showfoto
+rc_DATA = showfotoui.rc
+
+xdg_apps_DATA = showfoto.desktop