summaryrefslogtreecommitdiffstats
path: root/debian/htdig/htdig-3.2.0b6/Makefile.config
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2021-11-05 13:28:23 +0100
committerSlávek Banko <[email protected]>2021-11-05 13:28:23 +0100
commit8c787c3591c1c885b91a54128835b400858c5cca (patch)
treeeca1b776912a305c4d45b3964038278a2fae1ead /debian/htdig/htdig-3.2.0b6/Makefile.config
parentfe188b907cdf30dfdfe0eba9412e7f8749fec158 (diff)
downloadextra-dependencies-8c787c3591c1c885b91a54128835b400858c5cca.tar.gz
extra-dependencies-8c787c3591c1c885b91a54128835b400858c5cca.zip
DEB htdig: Added to repository.
Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'debian/htdig/htdig-3.2.0b6/Makefile.config')
-rw-r--r--debian/htdig/htdig-3.2.0b6/Makefile.config31
1 files changed, 31 insertions, 0 deletions
diff --git a/debian/htdig/htdig-3.2.0b6/Makefile.config b/debian/htdig/htdig-3.2.0b6/Makefile.config
new file mode 100644
index 00000000..d5719f8b
--- /dev/null
+++ b/debian/htdig/htdig-3.2.0b6/Makefile.config
@@ -0,0 +1,31 @@
+##
+## This file is part of ht://Dig
+##
+## Copyright (c) 1995-2004 The ht://Dig Group
+## For copyright details, see the file COPYING in your distribution
+## or the GNU Library General Public License version 2 or later
+## <http://www.gnu.org/copyleft/lgpl.html>
+
+#
+# To compile with profiling do the following:
+#
+# make CFLAGS=-g CXXFLAGS=-g PROFILING=-p all
+#
+
+AUTOMAKE_OPTIONS = foreign no-dependencies
+
+INCLUDES= -DDEFAULT_CONFIG_FILE=\"$(DEFAULT_CONFIG_FILE)\" \
+ -I$(top_srcdir)/include -I$(top_srcdir)/htlib \
+ -I$(top_srcdir)/htnet -I$(top_srcdir)/htcommon \
+ -I$(top_srcdir)/htword \
+ -I$(top_srcdir)/db -I$(top_builddir)/db \
+ $(LOCAL_DEFINES) $(PROFILING)
+
+HTLIBS= $(top_builddir)/htnet/libhtnet.la \
+ $(top_builddir)/htcommon/libcommon.la \
+ $(top_builddir)/htword/libhtword.la \
+ $(top_builddir)/htlib/libht.la \
+ $(top_builddir)/htcommon/libcommon.la \
+ $(top_builddir)/htword/libhtword.la \
+ $(top_builddir)/db/libhtdb.la \
+ $(top_builddir)/htlib/libht.la