summaryrefslogtreecommitdiffstats
path: root/debian/imlib/imlib-1.9.15/gdk_imlib/ChangeLog
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2020-09-11 14:38:47 +0900
committerMichele Calgaro <[email protected]>2020-09-11 14:38:47 +0900
commit884c8093d63402a1ad0b502244b791e3c6782be3 (patch)
treea600d4ab0d431a2bdfe4c15b70df43c14fbd8dd0 /debian/imlib/imlib-1.9.15/gdk_imlib/ChangeLog
parent14e1aa2006796f147f3f4811fb908a6b01e79253 (diff)
downloadextra-dependencies-884c8093d63402a1ad0b502244b791e3c6782be3.tar.gz
extra-dependencies-884c8093d63402a1ad0b502244b791e3c6782be3.zip
Added debian extra dependency packages.
Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'debian/imlib/imlib-1.9.15/gdk_imlib/ChangeLog')
-rw-r--r--debian/imlib/imlib-1.9.15/gdk_imlib/ChangeLog334
1 files changed, 334 insertions, 0 deletions
diff --git a/debian/imlib/imlib-1.9.15/gdk_imlib/ChangeLog b/debian/imlib/imlib-1.9.15/gdk_imlib/ChangeLog
new file mode 100644
index 00000000..af4ec88d
--- /dev/null
+++ b/debian/imlib/imlib-1.9.15/gdk_imlib/ChangeLog
@@ -0,0 +1,334 @@
+2004-08-20 Mark Crichton <[email protected]>
+
+ * io-bmp.c: Fixed BMP vunerability
+
+2002-09-11 jacob berkman <[email protected]>
+
+ * Makefile.am (common_ldflags): add -module
+
+2002-03-25 Mark Crichton <[email protected]>
+
+ * Makefile.am: Fixed some hacks to work around a broekn libtool.
+ Should work now.
+
+2002-03-22 Mark Crichton <[email protected]>
+
+ * Makefile.am: Bumped up rev numbers for 1.9.14. This is a brownbag
+ release...
+ * load.c: Fixed reported bug. If Imlib thought it needed a fallback,
+ bad things will happen.
+ * utils.c: Removed the open/close_helper functions. A little less
+ bloat now removed.
+
+2002-03-13 Mark Crichton <[email protected]>
+
+ * Makefile.am: Forgot to bump up the revision number. Doh.
+
+2002-03-04 Mark Crichton <[email protected]>
+
+ * io-*.c: Fixed potential buffer overflows. Were malloc-ing memory
+ and not checking to see if we were getting too much (or too little!).
+ Fixed with _gdk_malloc_image.
+
+ * load.c, save.c: Nuked use of external helpers for loading files.
+ Risks outweigh the benefits on this one.
+
+ * Makefile.am: Bumped up the revision number.
+
+2001-11-06 Mark Crichton <[email protected]>
+
+ * Makefile.am: Fix stupid libtool braindeadness. Bug #62654
+
+2001-09-10 Mark Crichton <[email protected]>
+
+ * Makefile.am: Argh, colors.c uses X libs, added dependency to
+ lib (also covers the XPM loader) Resolves bug #59915.
+
+2001-08-29 Mark Crichton <[email protected]>
+
+ * save.c, utils.c: Bug #56004. Improved error messages.
+
+2001-07-28 Mark Crichton <[email protected]>
+
+ * io-png.c: Fixed PNG loader to handle greyscale PNGs.
+ Resolves bug #57858
+
+2001-05-29 Mark Crichton <[email protected]>
+
+ * Makefile.am: Added loader dependencies on libgdk_imlib.la
+ Resolves bug #53863
+
+2001-05-29 Mark Crichton <[email protected]>
+
+ * misc.c: made x_error static. Resolves bug #52838
+
+2001-03-27 Mark Crichton <[email protected]>
+
+ * Makefile.am: cosmetic changes so vars can be changed at build
+ time.
+
+2000-08-29 Mark Crichton <[email protected]>
+
+ * rend.c: Added 12 bit rendering functions. Note, it's an
+ ugly hack, and really requires a rewrite of that code.
+
+ * misc.c (gdk_imlib_init): Added detection of a 12 bit visual.
+ (gdk_imlib_init_params): ditto
+
+ * utils.c: Disabled caching of generated data. The way you get
+ data from the Imlib cache is by a key, which is the filename.
+ Autogenerated data used a timestamp and *random number* as the
+ filename. So, you'd put stuff into the cache, and you can never
+ get it out. Disabled that, hopefully mem usage will look better.
+
+2000-05-20 Mark Crichton <[email protected]>
+
+ * misc.c (gdk_imlib_init): uses GdkRGB visual instead of X's
+ default visual. Behaves better on Solaris.
+ (gdk_imlib_init_params): ditto
+
+2000-04-14 Miguel de Icaza <[email protected]>
+
+ * misc.c (gdk_imlib_init_params): Use the correct parsing method
+ to get the visual number from the specified file.
+ (gdk_imlib_init): ditto.
+
+2000-02-24 Federico Mena Quintero <[email protected]>
+
+ * colors.c (alloc_colors): New function to allocate a color array.
+ This is the meaty part from gdk_imlib_load_colors() moved over to
+ its own function.
+ (gdk_imlib_load_colors): Use alloc_colors(). Do not print a
+ message if we cannot open the file, since we are already returning
+ an error code.
+ (gdk_imlib_load_default_colors__private): New function to allocate
+ a hardcoded default palette.
+ (PaletteAlloc): Made static, renamed from _gdk_imlib_PaletteAlloc.
+
+ * gdk_imlib_private.h: Added prototype for
+ gdk_imlib_load_default_colors__private().
+
+ * misc.c (gdk_imlib_init): Load a default palette if the palette
+ file could not be loaded. Bail out if no colors could be
+ allocated. Maybe we could just use BlackPixel and WhitePixel.
+
+2000-02-22 Morten Welinder <[email protected]>
+
+ * utils.c (gdk_imlib_create_image_from_xpm_data): Leak fix.
+
+1999-10-16 Kjartan Maraas <[email protected]>
+
+ * colors.c (PaletteLUTSet): Removed unused variables.
+
+1999-09-02 Raja R Harinath <[email protected]>
+
+ * rend.c (gdk_imlib_best_color_match):
+ Fix typo - `g_return_val_if_fail', not `g_return_val_fail'.
+ (_gdk_imlib_index_best_color_match): Likewise.
+
+1999-09-02 Pavel Machek <[email protected]>
+
+ * rend.c, globals.c, misc.c: No need to allocate structure
+ dynamically - it is needed, always.
+ Turned some fprintf(stderr) into g_return_val_if_fail as they
+ seem much cleaner to me.
+
+Fri Apr 2 15:28:28 1999 Asbjorn Pettersen <[email protected]>
+
+ * gdk_imlib_private.h: replace <sys/types.h>.
+ Needed for OS/2 version.
+
+1999-03-22 Pavel Machek <[email protected]>
+
+ * globals.c: robustness: you better keep gdk_imlib_data
+ initialized to NULL
+
+1999-02-11 Owen Taylor <[email protected]>
+
+ * misc.c: Don't overwrite existing locale settings, just
+ temporarily set LC_NUMERIC to "C", then restore it.
+
+1999-02-11 Tomas Ogren <[email protected]>
+
+ * utils.c: Since when did sizeof() be the same as strlen() on char*'s?
+ Also changed some malloc() + strcpy() -> strdup().
+
+1999-02-11 Tomas Ogren <[email protected]>
+
+ * Recommend 1.0.3 instead of 1.0.1 (if broken 1.0.2)
+
+1999-01-15 Miguel de Icaza <[email protected]>
+
+ * modules.c: Make the gdk_imlib_load_alpha and
+ gdk_imlib_inlined_png_to_image routines be exported.
+
+1999-01-16 Jeff Garzik <[email protected]>
+
+ * gdk_imlib_private.h:
+ Include gdkx.h for definition of gdk_window_foreign_new in misc.c.
+
+ * io-png.c (_loader_alpha_png):
+ Correct variable declarations to get rid of unused vars;
+
+ * modules.c (get_module_loader_saver):
+ Function now returns value. FIXME: The value is never used,
+ should probably be converted to a void function.
+
+1998-12-15 Miguel de Icaza <[email protected]>
+
+ * cache.c (gdk_imlib_set_cache_info, gdk_imlib_get_cache_info):
+ To control the cache externally.
+
+ * cache.c (gdk_imlib_flush_old_entries, gdk_imlib_flush_cache):
+ New empty routines. An API we might use in the future. Better
+ have it here before :-)
+
+1998-12-13 Miguel de Icaza <[email protected]>
+
+ * gdk_imlib_private.h: Moved structure members that depended on
+ HAVE_SHM to the end of the strucutre, where they do not hurt us.
+
+ The problem is as follows: If HAVE_SHM is defined at Imlib compile
+ time, then the Xdata structure is expanded to have these two
+ fields. Since we do not test for SHM in other places where we
+ access _gdk_imlib_data (which caused the Alpha crashes and the
+ duplicated icons due to the cache changes).
+
+1998-12-12 Miguel de Icaza <[email protected]>
+
+ * load.c (_gdk_imlib_LoadBMP): This code got lost by accident.
+
+1998-12-07 Miguel de Icaza <[email protected]>
+
+ * rend.c (gdk_imlib_render): Small typo correction.
+
+1998-12-06 Miguel de Icaza <[email protected]>
+
+ * misc.c (gdk_imlib_init): Use sizeof (s) instead of 4096 while
+ reading from the files. If someone ever changed these, we would
+ be in trouble.
+
+ * load.c (gdk_imlib_load_image): Use "file" instead of "fil" in
+ the call to _gdk_imlib_LoadTIFF (to make it work with wierd filenames).
+
+ * gdk_imlib_private.h: Clean up the name space. All of the
+ internal routines that were previously exposed are now prefixed
+ with _gdk_imlib_ instead of a mix of g_ and g.
+
+ GdkImlibData data variable "id" is now called _gdk_imlib_data.
+
+ * misc.c (HandleXError): This one is static.
+
+ * load.c (gdk_imlib_load_image): On GNOME we do not enable
+ spawning any external processes. Specially with the setup
+ currently implemented. Play it safe, we do not want to appear on
+ BUGTRAQ because of this feature.
+
+ * utils.c (gdk_imlib_set_image_red_curve,
+ gdk_imlib_set_image_green_curve): Code changes to make it work
+ with the new im->map setup. Make it check its input arguments,
+ according to GTK+/GDK conventions.
+ (
+ (gdk_imlib_apply_modifiers_to_rgb): Adapt as well.
+
+ * cache.c (gnullify_image): Release im->map if it exists.
+
+ * rend.c (gdk_imlib_render): Instead of testing for the defaults
+ here, we need only to test againt im->map now (as the im->map will
+ have a non-NULL value if a map even exists).
+
+ * utils.c (gcalc_map_tables): Test here if the color modifiers are
+ the defaults, and if so mark do not compute the modifier table,
+ and free any existing modifier table if it exists.
+
+Wed Sep 23 11:21:49 1998 Owen Taylor <[email protected]>
+
+ * rend.c (gdk_imlib_pixmap_foreign_new): Create pixmap
+ with g_new0, instead of g_new, to increase the chances
+ that all fields are initialized properly.
+
+1998-06-28 Miguel de Icaza <[email protected]>
+
+ * misc.c (gdk_imlib_init): Let the user use --no-xshm by checking
+ the setting on Gdk.
+
+1998-05-18 Miguel de Icaza <[email protected]>
+
+ * misc.c (gdk_imlib_init): Initialize uninitialized variables.
+
+ * rend.c: Remove unused variables.
+
+1998-05-07 Raja R Harinath <[email protected]>
+
+ * save.c (gdk_imlib_save_image): Replaces `snprintf' with
+ `g_snprintf' calls.
+ * utils.c (gdk_imlib_create_image_from_data): Likewise.
+
+Tue May 5 15:11:59 1998 Radek Doulik <[email protected]>
+
+ * replaced snprintf calls with g_snprintf ones, so it
+ compiles now on SunOS
+
+Sat Apr 11 12:30:13 1998 George Lebl <[email protected]>
+
+ * utils.c: fixed yet one more SIGFPE on alpha
+
+Fri Mar 20 00:02:43 1998 Tom Tromey <[email protected]>
+
+ * gdk_imlib.h: Replaced `()' with `(void)'.
+
+Sun Mar 15 12:34:45 1998 Owen Taylor <[email protected]>
+
+ * Makefile.am (INCLUDES): Added GTK_CFLAGS
+
+1998-02-25 Raja R Harinath <[email protected]>
+
+ * Makefile.am (DEFS): Define `SYSTEM_IMRC' too.
+
+1998-02-25 Federico Mena Quintero <[email protected]>
+
+ * misc.c (gdk_imlib_copy_image): The drawable passed to gdk_gc_new
+ should be the dest drawable, not the base imlib window. This
+ caused BadMatches all over the place (especially in copy_mask).
+ (gdk_imlib_copy_mask): Likewise.
+
+1998-02-24 Raja R Harinath <[email protected]>
+
+ * Makefile.am (DEFS): New var. Moved stuff from CFLAGS.
+ (INCLUDES): New var.
+
+1998-02-24 Mark Galassi <[email protected]>
+
+ * Makefile.am (libgdk_imlib_la_SOURCES):
+ (lib_LTLIBRARIES): changed gdk_imlib to use the libtool+automake
+ formalisms.
+
+ * load.c (gdk_imlib_load_image): changed JPEG_PATH to DJPEG_PROG
+ and removed %s/djpeg, sine DJPEG_PROG is the full program path.
+
+1998-02-17 Federico Mena Quintero <[email protected]>
+
+ * Makefile.in (install): Make directory for config files.
+
+ * configure.in: Fixed ENL_LIB_SUPPORT function for non-existing libraries.
+
+1998-02-16 Federico Mena Quintero <[email protected]>
+
+ * misc.c (gdk_imlib_init): I create a colormap specific to the
+ visual the base_window will be using. This fixes BadMatch errors
+ on machines with multiple visual/depth combinations.
+
+1998-02-17 The Rasterman <[email protected]>
+
+ * misc.c (gdk_imlib_init) Fixed visual stuff slightly, and Colormap
+ creation (so it only does so if the visual for the default and the
+ chosen visual mismatch), added function calls to retrieve Imlib's
+ visual and Colormap, plus endianess fixes for network displaying.
+
+1998-02-17 The Rasterman <[email protected]>
+
+ added system imrc config return function
+
+1998-02-18 The Rasterman <[email protected]>
+
+ Fixed load.c - missed a not (!) in an if clause