summaryrefslogtreecommitdiffstats
path: root/debian/pyrex/pyrex-0.9.9/Pyrex/Mac/Makefile
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-09-24 22:32:48 +0900
committerMichele Calgaro <[email protected]>2024-09-24 22:32:48 +0900
commit6d225e65e158e6547cb863d5558e955b3355449d (patch)
tree5fa5a62db33edc47242886a852b82336d53bf686 /debian/pyrex/pyrex-0.9.9/Pyrex/Mac/Makefile
parent2950a7d84514b9b2d9916afb06ff05fdabab3be7 (diff)
downloadextra-dependencies-6d225e65e158e6547cb863d5558e955b3355449d.tar.gz
extra-dependencies-6d225e65e158e6547cb863d5558e955b3355449d.zip
Removed pyrex, which is no longer required
Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'debian/pyrex/pyrex-0.9.9/Pyrex/Mac/Makefile')
-rw-r--r--debian/pyrex/pyrex-0.9.9/Pyrex/Mac/Makefile24
1 files changed, 0 insertions, 24 deletions
diff --git a/debian/pyrex/pyrex-0.9.9/Pyrex/Mac/Makefile b/debian/pyrex/pyrex-0.9.9/Pyrex/Mac/Makefile
deleted file mode 100644
index bf47d83f..00000000
--- a/debian/pyrex/pyrex-0.9.9/Pyrex/Mac/Makefile
+++ /dev/null
@@ -1,24 +0,0 @@
-# Makefile for Darwin
-
-# Change this to your Python source location
-PYTHON := /Local/Build/Pythonic/python/2.6.1
-
-# Version 2.3:
-#DYNOPT := -framework Python
-# Version 2.4+:
-DYNOPT := -undefined dynamic_lookup
-
-INCLUDE := -I$(PYTHON) -I$(PYTHON)/Include -I$(PYTHON)/Mac/Include
-
-CCOPTS := -fno-strict-aliasing -Wno-long-double -no-cpp-precomp \
- -mno-fused-madd -fno-common -dynamic
-
-LDOPTS := -Wl,-F.,-w -bundle $(DYNOPT) -framework Carbon
-
-all: _File.so
-
-_File.o: _Filemodule_patched.c
- gcc -c $(INCLUDE) $(OPTS) $< -o $@
-
-_File.so: _File.o
- gcc $(LDOPTS) $< -o $@