summaryrefslogtreecommitdiffstats
path: root/debian/opensync/opensync-0.22/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'debian/opensync/opensync-0.22/Makefile.am')
-rw-r--r--debian/opensync/opensync-0.22/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/debian/opensync/opensync-0.22/Makefile.am b/debian/opensync/opensync-0.22/Makefile.am
new file mode 100644
index 00000000..196953d3
--- /dev/null
+++ b/debian/opensync/opensync-0.22/Makefile.am
@@ -0,0 +1,32 @@
+## Process this file with automake to produce Makefile.in
+
+SUBDIRS = opensync osengine formats tests tools wrapper osplugin
+
+if BUILD_ENGINE
+OSENGINE_PC = osengine-1.0.pc
+endif
+
+pkgconfigdir = ${libdir}/pkgconfig
+pkgconfig_DATA = opensync-1.0.pc $(OSENGINE_PC)
+
+DISTCLEANFILES = \
+ opensync-1.0.pc \
+ opensync-1.0-uninstalled.pc \
+ osengine-1.0.pc \
+ osengine-1.0-uninstalled.pc \
+ py-compile
+
+EXTRA_DIST = \
+ opensync-1.0.pc.in \
+ osengine-1.0.pc.in \
+ misc/buildtest.sh \
+ misc/doxygen.css
+
+dist-hook:
+ find $(distdir) -name .svn -print0 | xargs -0 rm -rf
+ find $(distdir) -name autom4te.cache -print0 | xargs -0 rm -rf
+ find $(distdir) -name .libs -print0 | xargs -0 rm -rf
+ find $(distdir) -name .deps -print0 | xargs -0 rm -rf
+ find $(distdir) -name *.la -print0 | xargs -0 rm -rf
+ find $(distdir) -name *.lo -print0 | xargs -0 rm -rf
+ find $(distdir) -name Makefile -print0 | xargs -0 rm -rf