summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2018-12-23 02:03:40 +0100
committerSlávek Banko <[email protected]>2018-12-23 02:03:40 +0100
commit0816faa34e96a24644d9cf030cb05a78e71db3b6 (patch)
tree85fa23208ddefa21979ffc6870ce88126af51424 /po/CMakeLists.txt
parent4702db0e8bd645a41f448f14f3592ae57ab70112 (diff)
downloadfilelight-0816faa34e96a24644d9cf030cb05a78e71db3b6.tar.gz
filelight-0816faa34e96a24644d9cf030cb05a78e71db3b6.zip
Add CMakeL10n rules.
Create translation template. Modify CMake rules for translations to make them independent of languages. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
index 03be086..2ce6ef4 100644
--- a/po/CMakeLists.txt
+++ b/po/CMakeLists.txt
@@ -1,3 +1,9 @@
-# This file is genereted by trinity-automake-cmake-convert script by Fat-Zer
+# build translations if some are already available
-tde_auto_add_subdirectories( )
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} ${PROJECT_NAME}.po )
+
+foreach( _po ${po_files} )
+ string( REPLACE "/" ";" _path "${_po}" )
+ list( GET _path 0 _lang )
+ tde_create_translation( FILES ${_po} LANG ${_lang} )
+endforeach( )