summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-03-05 19:43:11 +0900
committerMichele Calgaro <[email protected]>2024-03-08 10:42:37 +0900
commit41f6d5afec703320378e38c0bcefb064d42337e4 (patch)
treebb46f79e50b5e15efc32f3456052c9b2873531bf /src/CMakeLists.txt
parentb24092d4d2cdfef0145f580a6d66be9b0e06db4c (diff)
downloadgwenview-41f6d5afec703320378e38c0bcefb064d42337e4.tar.gz
gwenview-41f6d5afec703320378e38c0bcefb064d42337e4.zip
Conversion to cmake building system
Signed-off-by: Michele Calgaro <[email protected]> (cherry picked from commit bc9bda10c93ebfb9862270576b445d1c2798d66d)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..3f4dd63
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,24 @@
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### subfolders
+
+add_subdirectory( app )
+add_subdirectory( desktopfiles )
+add_subdirectory( gvcore )
+add_subdirectory( gvdirpart )
+add_subdirectory( gvimagepart )
+add_subdirectory( imageutils )
+add_subdirectory( tools )
+add_subdirectory( tsthread )
+add_subdirectory( updates )