summaryrefslogtreecommitdiffstats
path: root/k9decmpeg/Makefile.am
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2023-08-06 01:07:46 +0200
committerSlávek Banko <[email protected]>2023-08-06 09:15:44 +0200
commit9f7c0362e26f62dc81769ab55a89e32c3c9a268d (patch)
treef02b303eedd1bf03d65de9f5d014c2c75d8af557 /k9decmpeg/Makefile.am
parent553df4a4357da7e17f21211201354c2006e76250 (diff)
downloadk9copy-9f7c0362e26f62dc81769ab55a89e32c3c9a268d.tar.gz
k9copy-9f7c0362e26f62dc81769ab55a89e32c3c9a268d.zip
Fix incorrect use of dvdread includes.
It seems that the library has been designed for use includes in the form "#include <dvdread/...>" while we used includes without the "dvdread/" prefix. This caused that instead of using the standard path detected from pkg-config, the expected path had to be added to to -I flag. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'k9decmpeg/Makefile.am')
-rw-r--r--k9decmpeg/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/k9decmpeg/Makefile.am b/k9decmpeg/Makefile.am
index 1d8911f..c47f0e4 100644
--- a/k9decmpeg/Makefile.am
+++ b/k9decmpeg/Makefile.am
@@ -12,7 +12,7 @@ libk9decmpeg_la_SOURCES = alloc.cpp attributes.h bswap.h convert_internal.h \
motion_comp_altivec.cpp motion_comp.cpp motion_comp_mmx.cpp motion_comp_vis.cpp mpeg2convert.h \
mpeg2.h mpeg2_internal.h rgb.cpp rgb_mmx.cpp rgb_vis.cpp slice.cpp tendra.h \
uyvy.cpp video_out.h vis.h vlc.h k9decodethread.cpp k9plaympeg2.cpp
-INCLUDES = -I/usr/include/dvdread -I$(top_srcdir)/k9vamps \
+INCLUDES = -I$(top_srcdir)/k9vamps \
-I$(top_srcdir)/libdvdnav -I$(top_srcdir)/libk9copy
noinst_HEADERS = k9decodethread.h k9plaympeg2.h